Joomla! 1.5 – upravljanje s piškotki

Joomla! 1.5 Piškotki – Slovenščina

EU cookie plugin

Za vas smo pripravili brezplačni vtičnik za nadzor piškotkov za Joomla! 1.5 v slovenskem jeziku.

Gre za novo verzijo plugina, ki vključuje Google Analytics, ter možnost lastnih povezav na “politiko zasebnosti” (za vsak piškotek posebej). Odpravljen pa je tudi bug v Internet Explorerju.

Plugin je še vedno v beta verziji, kar pomeni, da so še vedno možne kakšne manjše napake. Če jih najdete, nam prosim sporočite.

joomla

 

“Piškotki” plugin 1.0 beta za Joomla 1.5

Če vam je dodatek privarčeval čas ali denar,
se lahko zahvalite s simbolično donacijo.

Če bi zaradi kakršnega koli razloga želeli uporabljati staro verzijo, je dostopna tukaj:

 

Namestitev

Namestitev vtičnika je enostavna. Preprosto ga v .zip datoteki prenesite na svoj računalnik, na to pa v administracijskem vmesniku (Extension management) naložite na vašo Joomla spletno stran. Potrebno ga je še vklopit, ter izbrati želene nastavitve.

V kolikor vaša tema ne uporablja jquery knjižnice, ali uporablja starejšo verzijo, lahko uporabite tale plugin, morebitni stari jquery odstranite.

Kako deluje?

1. Deluje lahko tako v opt-out, kot opt-in načinu.

Opt-out način pomeni, da se najprej naložijo vsi piškotki vklopljeni, uporabnik pa ima možnost te piškotke onemogočiti.

Opt-in način pa omogoča, da se naložijo zgolj nujni piškotki, ostali pa šele, ko dobimo privoljenje uporabnika.

2. Vtičnik podpira 5 različnih skupin piškotkov in sicer:

  • Obvezni piškotki
  • Piškotki socialnih omrežij 
  • Piškotki za vodenje statistike
  • Piškotki za namen oglaševanja
  • Drugi piškotki

Vsakega od teh lahko vklopite glede na vaše potrebe, vsakemu lahko po potrebi spremenite ime in opis (zaenkrat še ne), ter zraven po želji dodate povezavo s podrobnejšim opisom piškotkov, ki jih uporabljate.

V kolikor ne veste katere piškotke uporablja vaša spletna stran, si preberite prispevek o tem, kako lahko to preverite.

Plugin že ima integrirano podporo za Google Analytics. Če ga uporabljate, vam svetujemo da svojo google analytics kodo vnesete v ta plugin, staro kodo, pa izbrišete.

piskotki-joomla1-p

3. Izgled

Obvestilo o piškotkih se lahko pojavlja zgoraj ali spodaj na spletni strani. Izbirate lahko tudi ali želite prikazovati povezavo “Zasebnost” do možnosti spremembe nastavitev (to je iz vidika zakonodaje priporočljivo). Ta povezava lahko počiva levo, desno, spodaj ali zgoraj. Trenutno sta na voljo dve barvni kombinaciji, ki jih plugin uporablja. V temni in v svetli barvi. Barve in izgled je mogoče popolnoma prilagoditi vaši spletni strani s pomočjo CSS-a.

Namestitev

Namestitev vtičnika je enostavna. Preprosto ga v .zip datoteki prenesite na svoj računalnik, na to pa v administracijskem vmesniku (Extension management) namestite. Potrebno ga je še vklopit, ter izbrati želene nastavitve.

Dodatek “Piškotki”  potrebuje knjižnico jquery za pravilno delovanje. Uporaba Jquery je postala standard v zadnjih nekaj letih. V kolikor vaša tema še ne uporablja te knjižnice, jo je potrebno dodati. Lahko jo dodate ročno, ali pa preko katerega od brezplačnih dodatkov.

Pozor:

Zgolj namestitev vtičnika ni dovolj za skladnost z zakonodajo.
Da vtičnik lahko nadzira nalaganje vaših piškotkov, je potrebno nekoliko modificirat tudi tisti del kode, ki piškotke ustvarja. Tega vam le v primeru Google Analytics ni potrebno narediti, saj lahko svoj GA ID vnesete kar v Piškotki plugin.

V kratkem bomo pripravili tudi podrobnejša, osnove, pa najdete zaenkrat tu: navodila za blokiranje piškotkov.

 

 

19 thoughts on “Joomla! 1.5 – upravljanje s piškotki

  1. Matej

    Zdravo!

    Na eno spletno stran, ki deluje na Joomli 1.5.26 hočem dodati tale plugin, ampak zadeva noče delovati. Javi mi, da potebujem vsaj jQuery1.4.4(čeprov v header-ju naložim latest verzijo), kasneje mi pa tudi ne prikaže obrazca za strinjanje s pogoji. Kje ga pečem?

    Gre se za stran http://www.zok-triglav.si/

    lp, Matej

    Reply
  2. Dejan

    nekaj me zanima…stran je narejena v Joomli in uporablja tudi Joomfish (za večjezično). kako prevesti ta plugin tudi za drugi jezik, namreč v Joomfish komponenti ni besedila, ki se pojavi na strani…saj je le ta v test.js datoteki, ki se nahaja v *\plugins\system\piskotki mapi.

    Reply
    1. Blanka

      tole mi napiše

      JFTP::login: Unable to login
      JFTP::store: Unable to use passive mode
      JInstaller::install: Failed to copy file: /domains/plg_jsapiintegrator_v1.0_j1.5/jsapiintegrator.php to /domains/fizioterapija-mediko.si/public_html/plugins/system/jsapiintegrator.php

      Reply
      1. admin

        izgleda kot, da bi šlo za “write” omejitve na direktoriju. Če drugače ne, odzipaj vse skupaj in preprosto preko FTPja kopiraj mapo “piskotki” v …/plugins/system/

        Reply
      1. Grega

        sedaj sem ugotovil, da dela samo v FF, ne pa v ie9-10 in chrome. Torej ni tistega popupa na vrhu, samo zavihek na dnu se prikaže.

        Reply
        1. admin

          Prikaz v IE je bil problem prejšnje verzije plugina Piškotki. Naloži si zadnjo verzijo. V kolikor pa imaš zadnjo verzijo nameščeno, preveri še če uporablja tema jquery (vsaj 1.4.4).

          Reply
  3. robert

    Ali obstaja tudi kje kašen plugin za joomla 1.0.13.

    Sem vse pregledal, narediti ga pa ne zanam.

    Hvala za pomoč

    Robert

    Reply
    1. admin

      Mislim da bi modul za 1.5 moral delovati. Nisem pa ga še preiskusil, saj nimam nobene instalacije J 1.0

      Reply

Leave a Reply to Branko Cancel reply

Your email address will not be published. Required fields are marked *