WordPress vtičnik za upravljanje piškotkov

WordPress EU cookie plugin – Slovenščina

Ta verzija deluje na WP3.6

Za vas smo pripravili NOV brezplačni vtičnik za nadzor piškotkov na WordPress platformi v slovenskem jeziku. Isti vtičnik uporabljamo tudi mi na naši spletni strani. Plugin je še vedno v beta verziji, kar pomeni, da je namenjen predvsem testiranju. Nova različica “Piškotki” plugina prinaša nekaj novosti, zato tudi uporabnikom prejšnje verzije svetujemo, da si naložijo novo.

V novi verziji je nekaj sprememb:

  • Omogočena integrirana Google analytics statistika
  • Možnost anonimizacije IP naslovov
  • Popravljen IE bug
  • Rešena težava nedelovanja na določenih temah

Najdete pa lahko še kakšen dodaten sladkorček. Pred namestitvijo je potrebno izbrisati morebitno staro verzijo.

wordpress

NOV Piškotki plugin 1.3 beta za WordPress

Če vam je dodatek privarčeval čas ali denar,
se lahko zahvalite s simbolično donacijo.

Če bi zaradi kakršnih koli razlogov želeli uporabljati starejšo verzijo, jo lahko dobite tukaj:

Kako deluje?

1. Deluje lahko tako v opt-out, kot opt-in načinu.

Opt-out način pomeni, da se najprej naložijo vsi piškotki vklopljeni, uporabnik pa ima možnost te piškotke onemogočiti.

Opt-in način pa omogoča, da se naložijo zgolj nujni piškotki, ostali pa šele, ko dobimo privoljenje uporabnika.

2. Vtičnik podpira 5 različnih skupin piškotkov in sicer:

  • Obvezni piškotki
  • Piškotki socialnih omrežij 
  • Piškotki za vodenje statistike
  • Piškotki za namen oglaševanja
  • Drugi piškotki

Vsakega od teh lahko vklopite glede na vaše potrebe, vsakemu lahko po potrebi spremenite ime in opis, ter zraven po želji dodate povezavo s podrobnejšim opisom piškotkov, ki jih uporabljate.

V kolikor ne veste katere piškotke uporablja vaša spletna stran, si preberite prispevek o tem, kako lahko to preverite.

Možne nastavitve:

piskotkiWP

 

Če vnesete vašo Google Analytics UA identifikacijo v dodatek “Piškotki” (in se ta ne nalaga nikjer drugje), potem ni potrebno posegati v kodo (razen za morebitne ostale piškotke), blokiranje teh piškotkov bo delovalo samo od sebe.

3. Izgled

Obvestilo o piškotkih se lahko pojavlja zgoraj ali spodaj na spletni strani. Izbirate lahko tudi ali želite prikazovati povezavo “Zasebnost” do možnosti spremembe nastavitev (to je iz vidika zakonodaje priporočljivo). Ta povezava lahko počiva levo, desno, spodaj ali zgoraj. Trenutno sta na voljo dve barvni kombinaciji, ki jih plugin uporablja. V temni in v svetli barvi. Barve in izgled je mogoče popolnoma prilagoditi vaši spletni strani s pomočjo CSS-a. V kolikor niste vešči v programiranju in bi želeli prilagojen prikaz posebej za vašo stran, se lahko obrnete na nas.

Namestitev

Namestitev vtičnika je enostavna. Preprosto ga v .zip datoteki prenesite na svojo spletno stran in vklopite. Pod “Nastavitve” oz. “Settings” se vam bo prikazal novi zavihek “Piškotki”. S klikom nanj boste lahko prikazovanje in delovanje plugina prilagodili vam.

Pozor:

Zgolj namestitev vtičnika ni dovolj za skladnost z zakonodajo.
Da vtičnik lahko nadzira nalaganje vaših piškotkov, je potrebno nekoliko modificirat tudi tisti del kode, ki piškotke ustvarja.

Za ta primer smo pripravili navodila, kako to lahko storite sami. V kolikor potrebujete pomoč, smo na voljo.

Opozarjamo tudi, da gre za testno in razvijajočo se verzijo in ne izključujemo morebitnih napak pri delovanju. Vtičnik pri nam sicer deluje odlično. V primeru kakršnih koli težav pri delovanju, nam te javite. Le tako lahko morebitne napake dolgoročno odpravimo.

 

 

85 thoughts on “WordPress vtičnik za upravljanje piškotkov

  1. Domen

    Zdravo,

    dober plugin vendar mi na verziji WP 3.5.1 ne deluje na IE9 in na FF-ju 21.0 (ne pojavi se okno za potrditev/nastavitev).
    Deluje mi samo v Chrom-u.

    LP Domen

    Reply
  2. domen

    Pozdravljeni
    Imam probleme z delovanjem vašega vtičnika na microsoft internet explorerju. Na chromu in firefoxu deluje BP. Ste imeli pri ostalih podobne probleme, ali zadeva še ni integrirana?

    hvala za pomoč

    Reply
  3. Žiga

    Živjo,

    imam par zadev:

    1. mislim, da je v nastavitvah Advanced opt-out in opt-in glih kontra glede na delovanje na strani
    2. a se bo lahko tut kej tekst prilagodil na vtičniku in dodala kaka povezava do podstrani?
    3. Če se doda GA kodo že v nastavitvah jo preden jo naloži zablokira, sicer ne?

    lpž

    Reply
    1. admin

      1. Bom preveril, možno 🙂
      2. Povezave do podstrani lahko trenutno daš pod vsako vrsto piškotka….
      3. GA kodo se bo vneslo kar v plugin, v novi verziji že to podpira. opt-in način jo zablokira preden se izvede, opt-out pa ne.

      Reply
  4. Miha

    Pozdravljeni!

    Zanima me, če je plugin še na voljo, ker download ne deluje več.

    LP, Miha

    Reply
  5. Andrej Post author

    Emmmm, meni download dela. Mogoče si imel ravno “srečo” in si klikal ko sem menjaval gumbe? 🙂

    Reply
  6. Saša

    Pozdravljen!

    Ta modul sem že sprobavala iz strani silktide in mi je res všeč! Ker se pa na to nič kaj dosti ne spoznam imam težave s prilagoditvijo..boste mogoče naredili tut kak modul za prestashop?

    LP, Saša

    Reply
    1. admin

      Dosti je povpraševanja za tak modul, tako za Prestashop, OpenCart in Magento. V tem trenutku ne morem nič obljubit. Če bo čas za vse skupaj, potem bom naredil še kakšen modul za katero izmed spletnih trgovin.

      Reply
  7. stanem

    Zdravo,

    kako je pa s prikazovanjem obvestila uporabnikom, ki spletno stran obiščejo iz tujine? Nekaj sem gledal po pluginu in videl, da so zadeve v neki meri pripravljene za angleško verzijo, vendar se ne spoznam toliko, da bi vedel ali zadeve delujejo ali ne.

    Lp. S

    Reply
    1. admin

      V tem trenutku še ni večjezičnosti. Je pa zelo možno, da bo v prihodnosti. Na razvojni verziji že testiram geolokacijo, je pa še kar nekaj dela, do tega, da bi se obiskovalcu teksti prikazovali v jeziku od koder so (oz. vsaj v angleščini).

      Reply
      1. darko

        komaj čakam da bo večjezičnost oz. vsaj da določiš za katere države se naj pojavlja 🙂
        plugin se upejta preko wordpressa ali je treba preverjati na vaši strani?

        Reply
        1. admin

          Zaenkrat je zgolj tu na moji strani, ko se primerno stestira, pripravim še angleško različico in dam na uradno stran.

          Reply
    1. admin

      WordPress ima že vgrajen jQuery, tako da preveri zakaj se ti ne nalaga. Napaka, ki jo omenjaš ti je sicer pogosta za kako staro verzijo Joomle, ne pa za WordPress.

      Reply
      1. OblakJ

        Zadnja verzija wordpressa in vsi (ostali) plugini delujejo tako, kot bi morali. Zanimivo.

        Reply
      2. Tomaz

        Zdravo,

        tudi meni javi enako napako: Potrebujete vsaj jQuery 1.4.4

        Zadnja verzija WP, tudi plugini so up to date.

        Zanimivo, da pa na drugi stranim kjer sem namestil ta plugin pred tednom dni, ni javilo napake.

        Kakšna ideja?

        Hvala in lp, Tomaž

        Reply
        1. Tomaz

          Ugotovil sem, da je problem delal plugin “Kino Events Calendar”, ki ima Last Updated: 2011-8-12. Sem ga izključil in deluje odlično.

          Hvala za odličen plugin.

          Reply
  8. Aleks

    Meni – čeprav imam v nastavitvah vklopljeno vrsto piškotkov “Statistika”, sploh ne pokaže dialoga za soglasje, in ko kliknem na “Zasebnost” mi izpiše, da stran ne uporablja nobenih piškotkov. Nekaj torej ne dela pravilno.

    Reply
    1. Andrej Post author

      je WordPress posodobljen na zadnjo verzijo? Lahko pošlješ tudi link in preverim kje je problem.

      Reply
      1. Aleks

        Hja, ne morem laufati spletne s trani z nedelujočim pluginom.
        Mrzlično čakam novo verzijo…

        Reply
    2. Miha

      Ista napaka pri meni. Na enih straneh dela ok, na enih pa ne. Povsod zadnji WP in vsi plugini up to date.

      Reply
      1. Andrej Post author

        v kratkem bo zunaj nova verzija, mislim da bo tista delovala (še) boljše.

        Reply
        1. Miha

          V kratkem pomeni danes/jutri? 🙂

          P.S. Ure na tej strani nimate pravilno nastavljene. 🙂 😉

          Reply
          1. Andrej Post author

            danes ali jutri 🙂
            uro sem popravil… ta stran bi bila lahko lepša in boljša, vendar glavno da služi namenu.

  9. Brane

    Zdravo!

    V Firefoxu se mi na začetku ne pojavlja orodna vrstica spodaj vendar kar takoj zavihek zasebnost. V Chromu dela vse tako kot mora. Se je morda že kdo soočil s takšno težavo? Hvala za odgovor in odličen plugin!

    lp

    Reply
    1. Andrej Post author

      Poskusi izbrisat vse piškotke in osvežit stran ali poskusi iz računalnika, s katerega še nisi dostopal. V Firefoxu po izkušnjah vse deluje super.

      Reply
  10. Pajekroma

    Nikakor mi ne sprejme spremembe povezave na besedo “Kaj so piškotki” , ki bi jo rad preusmeril na svojo stran z opisom kaj so piškotki.

    Link editiram direktno na “plugins Editor”

    Hvala.

    Reply
    1. admin

      Za Blogger mora poskrbeti Google 🙂
      Če te skrbi glede tag, napiši zgolj pogoje zasebnosti.

      Reply
      1. AS

        Glede na to, da imam svojo domeno, ali velja enako kot pri wordpressu?
        Nikjer na internetu nisem našla ničesar v povezavi z bloggerjem (niti bloga, ki bi imel opozorilo ali kakšnega tutoriala; za wordpress jih je ogromno).

        Reply
  11. Almira

    Zdravo,
    a če imaš čisto navaden blog na wordpressu, je potem takem tudi potrebno poskrbeti za te piškote 😀

    Reply
    1. admin

      Če imaš WordPress na lastnem strežniku, potem DA, je potrebno. Če pa na wordpress.com, potem tebi ni potrebno (nisem sicer bral pogojev uporabe). Načeloma mora lastnik (torej WordPress.com) poskrbet za to.

      Reply
  12. Marko

    Kako bi za določeno stran ali podstran (statično) nastavil drug jezik za opozorila?

    Reply
    1. admin

      Spremeniti moraš javascript, ki ga vneseš, če pogledaš kodo:
      <script type="text/javascript">
      // <![CDATA[
      cc.initialise({
      cookies: {
      necessary: {
      title: 'Obvezni piškotki',
      description: 'Posamezni piškotki so nujni za delovanje naše spletne strani in jih ni moč onemogočiti.',
      link: ''
      },

      analytics: {
      title: 'Statistika',
      description: 'Dovoljujem anonimno spremljanje statistike obiska.',
      link: 'http://piskotki.net/zasebnost-na-piskotki-net#statistika'
      },
      },
      settings: {style: "dark",bannerPosition: "bottom",tagPosition: "vertical-left",consenttype: "implicit",}
      });
      // ]]>

      </script>

      Torej spremeniš Title in description za vsak piškotek… Za več možnosti pa preveri na http://silktide.com/cookieconsent/documentation/how-does-it-work na čemer temelji tale vtičnik.

      Reply
  13. mrmr

    The package could not be installed. PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature
    🙁

    Reply
    1. mrmr

      plugin je sedaj mogoče inštalirati, sam še vedno se mi ne pokaže na strani. Mislim da je fora v wp temi. Sam ne bi pa znal tega popravt 🙂

      Reply
  14. Aleks

    Čestitam, vezija 1.2 dela in je zelo uporabna (posebej zaradi integracije GA)!

    Bravo!

    Vse, kar bi si želel je le še to, da plugin daste na uradni depository, da ga bomo tudi z lahkoto posodavljali!

    Reply
    1. Andrej Post author

      Hvala za pohvale. Plan je, da gre plugin na uradni repozitorij, samo je najprej potrebno rešit večjezičnost…

      Reply
  15. Pingback: Wordpress vtičnik za piškotke – WP Cookie plugin | Refleks blog

  16. Nejc Žorga Dulmin

    Velika hvala za plugin! Super, da ste vključili intergracijo z GA!

    Problem je na mobilnem brskalniku. Na iPhonu se tako v Safariju kot v Chrome obvestilo prikaže čez celo stran …

    Reply
    1. admin

      Prikaz na mobilnih telefonih morda res ni idealen, ga pa je mogoče popravit z malo cssa.
      Po drugi strani pa ta vsaj deluje na mobilnih telefonih. 🙂

      Reply
  17. Matjaž

    Nikakor mi ne sprejme spremembe povezave na besedo “Kaj so piškotki” , ki bi jo rad preusmeril na svojo stran z opisom kaj so piškotki.

    Link editiram direktno na “plugins Editor” pa ne sprejme.

    Hvala.

    Reply
  18. Uroš

    Pozdravljeni,

    tudi meni na strani izpise, da stran ne uporablja cookiejev, ceprav mi jih je program cookie checker nasel kar nekaj… WP je up to date.

    Lp
    uroš

    Reply
  19. Klemen

    Zdravo,

    ali lahko navedete imena razredov, ki se uporabljajo za določanje barv ozadja pojavnega okna in barve gumba?

    Hvala.

    Reply
  20. Nataša

    Vaš plugin deluje v redu, imam samo en problem. Na operacijskem sistemu android mi zginejo šumniki. Najprej se prikažejo, a takoj ko se zažene tudi vaš plugin zginejo. Imate mogoče kakšno rešitev.

    Hvala

    Reply
    1. admin

      Najverjetneje prihaja do konflikta ob nalaganju Google fonta, tega je mogoče izklopit z manjšim posegom v kodo (test.js, tam okrog vrstice 1500). Lahko tudi dodaš namesto &subset=latin tole: &subset=latin-ext

      Reply
  21. Aleks

    V piskotki.php, vrstica 292 in naslednjih je potrebno dodati dosledno preverjanje če so spremenljivke postavljene.
    if (isset($options[‘style’]))
    echo ‘style: “‘.$options[‘style’].'”,’;

    Na nekaterih strežnikih je brez tega preverjanja bila zgenerirana napaka, ki je bila tudi izpisana v html output.
    Kolnkretno mi potem slibox galerija slik zaradi tega ni delala.

    LP Aleks

    Reply
  22. Oliver

    Tudi meni so se nedavno (po raznih posodobitvah) pojavile razne napake povezane z jQuery. Te sem uspešno odpravil s pluginom WP jQuery CDN pri katerem sem nastavil: Google Ajax API jQuery CDN, verzija 1.7.1.

    Pa še en nasvet za tiste, ki na svoje spletne strani vdelujete YouTube videoposnetke. Ti se na spletnih straneh ne prikazujejo pod obvestilom o piškotkih ampak nad tem in sicer je za to “kriv” YouTube. Zadevo rešite tako, da pri kodi za vdelovanje videoposnetka na koncu url naslova dodate parameter “?wmode=opaque”.

    Primer: <iframe width="480" height="385" src="http://www.youtube.com/embed/LnFuTTSrzSw?wmode=opaque" frameborder="0" allowfullscreen></iframe>

    Reply
    1. Oliver

      Pozabil sem napisati, da YouTube tudi ustvarja piškotke ob vdelovanju videoposnetkov zato je treba pri generiranju kode na YT obvezno izbrati “Omogoči način s poostreno zasebnostjo”. 🙂

      Reply
  23. ideep

    Zdravo,

    Meni je delalo vse BP do pred kratkim.. danes se mi sploh ne prikaže nič več.. sprobala sem vse možne opcije..

    zasebnost zavihka ni, opcije za izbiro prav tako ne..

    Reply
    1. admin

      plugin piškotki ne kliče zunanje kode, tako da razlog ne more biti v pluginu, da bi se kar koli samo od sebe spremenilo. Je pa seveda možno, da je kakšen konflikt z kakšnim drugim pluginom…

      Reply
  24. ideep

    res mi ni jasno.. izklopla sem vsakega posebej, zbrisala cookieje pa nič se ne spremeni.. obstaja kakšna stvar ki javi napako pri pluginih

    Reply
  25. Grega

    Pozdravljeni,

    Na spletni strani sem posodobil WP na 3.6.1. Ko sem vtičnik aktiviral (naložil sem zadnjo verzijo), mi noče shraniti nastavitev, ki jih izberem, shrani pa mi GA kodo. Kaj lahko naredim?

    Reply
  26. gojc

    Pozdravljeni.
    Hvala za vaš trud in delo.
    Do sedaj je vse delalo bp. Sedaj sem upgradal wp na 3.6.1 in kar naenkrat se mi pojavi potrebujete najmanj jQuery 1.4.4. Na koncu ugotovim, da stranb dela brez tega obvestila, če izklopim vaš vtičnik. Na vaši strani potegnem dol 1.3 beta. Instaliram, na vtičniku mi še vedno piše ista verzija 0.21 in težava z Jquerijem ostaja. Kakšen nasvet?

    Reply
    1. gojc

      Zanimivo, sedaj sem šel ostale plugine izklopit in nazaj vklopit in zaenkrat dela. Poročam kako bo naprej

      Reply
      1. admin

        Zadnja verzija piškotkov bi morala dobro delovati. Prejšnja je imela bug, ki je slabo preverjal verzijo jQuerya.

        Reply
  27. jernej

    Njprej havla za super plugin. Imam pa eno vprašanje:
    -uporabljam Universal analytics, v pluginu imam vključeno anonomiziraj IP. Je dovol opt-out način ali mora biti opt-in?

    Reply
  28. h

    V vašem plugin v verziji 1.3 beta še vedno v piskotki.php piše Version: 0.21, mislim da bi bilo potrebno spremenit v 1.3.
    Hvala za vašo poslovenjeno verzijo.
    Vse dobro
    H

    Reply
  29. Janez

    Hvala za vaš plugin, ki je odličen. Le na moji strani, kjer uporabljam WP temo, ki sem jo kupil, mi po kliku na gumb Zapri, strani ne naloži ponovno ampak ostane na naslovu janezravnikar.com/#

    Mi lahko svetujete.

    Hvala

    Reply
    1. Andrej Post author

      Potrebno je ugotoviti, kje prihaja do konflikta. Za začetek bi bilo dobro poskusiti izklopiti vse druge plugine in preveriti, ali deluje brez njih. Nato pa se vklaplja enega po enega nazaj.

      Reply
  30. Marko

    Zdravo!
    Kako je z večjezičnostjo? Naredil sem kopijo datoteke test.js in jo prevedel (stran glede na jezik prebere SI ali EN verzijo), teksta iz slike pa ne gre prevesti, ker je tudi v administratorski strani fiksno določen tako.

    Kakšna ideja, kako to urediti?

    Reply

Leave a Reply to OblakJ Cancel reply

Your email address will not be published. Required fields are marked *